#406 running problem

snapshot
closed-fixed
Rob Manning
8
2006-08-03
2006-08-02
Anonymous
No

Hi all.
Not really a bug; last two snapshot versions run only
with JDK 1.5

With jdk 1.4.2_12:
Exception in thread "main"
java.lang.UnsupportedClassVersionError:
net/sourceforge/squirrel_sql/client/Main (Unsupported
major.minor version 49.0)

Gil

Discussion

  • Rob Manning
    Rob Manning
    2006-08-02

    Logged In: YES
    user_id=1287991

    Gil,

    Thanks for bringing that to our attention. It's not our
    intent ( at least not right now ) to exclude people who
    use 1.4. I recently updated our build machine to use
    1.5 and forgot to turn on the compatibility switch for
    the compiler. I'll see that it gets fixed.

    Rob

     
  • Rob Manning
    Rob Manning
    2006-08-02

    • milestone: --> snapshot
    • assigned_to: nobody --> manningr
    • priority: 5 --> 8
    • labels: --> Build Scripts
    • status: open --> open-accepted
     
  • Rob Manning
    Rob Manning
    2006-08-03

    Logged In: YES
    user_id=1287991

    Gil,

    I modified the build scripts to target 1.4 JVM, regardless
    of the version of the compiler that is used (1.4 and above).
    Also tested with JRE 1.4 and JRE 1.5 and both start up
    fine now. The new snapshot that this is available in is
    Snapshot-20060803_2459 which is located here:
    https://sourceforge.net/project/showfiles.php?group_id=28383&package_id=158128&release_id=436659

    Rob Manning

     
  • Rob Manning
    Rob Manning
    2006-08-03

    • status: open-accepted --> closed-fixed
     
  • Logged In: NO

    Rob,
    thank you very much
    of course, Snapshot-20060803_2459 version works fine

    gil