Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#20 [4.1] Add command-line parameter that indicates the version

open
nobody
None
5
2010-09-22
2010-09-22
Anonymous
No

With more compressors than just gzip being supported now, scripts will need to know which version of the squashfs tools is installed in the system. I suggest to add a command-line parameter that indicates the version -- any of "-v", "-V", or "--version".

Discussion

  • BTW, indicating the version number seems appropriate for all kinds of screen output -- during file system creation, when showing the usage instructions ("mksquashfs --help"), etc.