squashfs for kernel 2.4.19-rmk6 ?

Help
2007-05-09
2013-05-29
  • Hello,

    Is there an old squashfs version that will work fine with a 2.4.19-rmk6 kernel ?

    I tried the patch for 2.4.20 but it fails - I think because there is no lib/zlib_{deflate,inflate} in this old kernel...

    And no, unfortunately I can't use a newer kernel...

    Many thanks,

    Markus Grunwald

     
    • There used to be a Squashfs patch for 2.4.19 but I dropped support a couple of years ago.

      There are, however, not too many differences between the patch for 2.4.19 and 2.4.20.  When I get time I'll see if I can produce a patch for 2.4.19.  I'm currently at the Ubuntu UDS and so it won't be for a couple of days.

       
      • Hello,

        this would be _extremely_ wonderful. Please mail me as soon as you have the patch.

        Big "TIA",
        Markus

         
      • Hello,

        I just wanted to ask if you can already estimate if/when this will work ?

        Regards,
        Markus