#30 10g 'Load all in one' problem

Released in 1.4x
closed-fixed
Drzewiecki T.
SQL (23)
5
2006-01-31
2006-01-16
Drzewiecki T.
No

1. Create and drop one table. Execute
SELECT * FROM recyclebin
It shows > 0 rows.

2. Go to 'Object List' -> 'Select All'

3. Try to do 'Load "all in one"'.
You'll see:

Object "xxx.BIN$/y1OIUimTWemk88BLq0JDQ==$0" is not
found in the dictionary.

Program: SQLTools 1.4.1 Beta build 66 (for trouble-
shooting)
Location: .\DbBrowser\DbSourceWnd.cpp(756).

Discussion

  • Drzewiecki T.
    Drzewiecki T.
    2006-01-16

    Logged In: YES
    user_id=747155

    This behaviour is caused by:
    'SELECT * FROM SYS.ALL_TAB_COMMENTS...'

    This table shows also objects from a new in 10g special
    table RECYCLEBIN.

    I removed this problem by removing from the second
    statement tables which name begins with 'BIN$'.

    Further details in Loader_Table.cpp:prepare_cursor().

     
  • Drzewiecki T.
    Drzewiecki T.
    2006-01-16

    • status: open --> closed-fixed
     
  • Drzewiecki T.
    Drzewiecki T.
    2006-01-16

    Logged In: YES
    user_id=747155

    This behaviour is caused by:
    'SELECT * FROM SYS.ALL_TAB_COMMENTS...'

    This table shows also objects from a new in 10g special
    table RECYCLEBIN.

    I removed this problem by removing from the second
    statement tables which name begins with 'BIN$'.

    Further details in Loader_Table.cpp:prepare_cursor().

     
  • Drzewiecki T.
    Drzewiecki T.
    2006-01-31

    • milestone: 455736 --> Released in 1.4x