Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#20 Triggers processing problem (Oracle8i)

Future
closed-fixed
nobody
SQL (23)
5
2011-10-05
2005-04-18
Drzewiecki T.
No

I found, that on Oracle8i 8.1.7.4.1 (9i is OK) exists
problem in triggers processing. I checked old versions -
it was working properly in '1.4.1 Beta build 589'.

Example (open trigger in editor):
In the old version:
"
CREATE OR REPLACE TRIGGER xyz_trig
AFTER INSERT OR UPDATE
ON xyz FOR EACH ROW
BEGIN
"

In the new version (b63,b64,b66)
"
CREATE OR REPLACE TRIGGER xyz_trig
AFTER INSERT OR UPDATE
ON xyz FOR each ROW

BEGIN
"

There is one empty line! I don't know why in 9i it is
working properly. In TOAD everything is OK on each
database.

Discussion

  • Drzewiecki T.
    Drzewiecki T.
    2005-04-18

    Logged In: YES
    user_id=747155

    On Oracle 8.1.7.0.0 it looks, that it appears rarely.
    On 8.1.7.4.1 it also shows sometimes 2 empty lines:
    "
    CREATE OR REPLACE TRIGGER xyz_trg_p3
    AFTER INSERT OR UPDATE
    ON xyz

    BEGIN
    something;
    END ;

    /
    "

    Also strange is placement for ending "/". I found also, that
    also version 1.4.1b589 for some triggers shows wrong result.

     
  • Logged In: YES
    user_id=423922

    I cannot reproduce this problem with 8.1.7.0.0. Please look
    at all/user_triggers: how description looks like?

     
  • Drzewiecki T.
    Drzewiecki T.
    2005-04-27

    • priority: 7 --> 5
     
  • Drzewiecki T.
    Drzewiecki T.
    2005-06-21

    Logged In: YES
    user_id=747155

    I checked:
    SELECT description FROM all_triggers...
    Description in 'wrong' triggers has 1-4 empty lines at the end.

    Solution:
    We should truncate empty lines if there are (of course) at the
    end! In the middle very often blank lines are left intentionally.

     
  • Drzewiecki T.
    Drzewiecki T.
    2005-06-22

    Logged In: YES
    user_id=747155

    On 8i TOAD truncates empty lines at the end, even if there
    exists.

     
  • Drzewiecki T.
    Drzewiecki T.
    2006-01-19

    • milestone: 455736 --> Future
     
    • status: open --> closed
     
    • status: closed --> closed-fixed