Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Strange behavior with color font

2008-03-14
2013-04-16
  • Hi,

    I changed the font color from PL/SQL Category - Text Attribute to Foreground=white and Background=black.
    When I do a simple select like select * from table the word with the table name disappears. The font assumes the Attribute Foreground=black.
    If I disconnect from database everything becomes normal.

    Note.:
    These attribute settings are the same I use actually in SQLTools and it's working fine.

    Thanks,
    Alexandre Tarquino

     
    • randolf_geist
      randolf_geist
      2008-03-14

      Hi Alexandre,

      I can't exactly follow your example: I'm missing your setting e.g. regarding "Selected Text" which by default corresponds to what you've set for normal "Text".

      But your issue is very likely caused by the new feature "Enhanced Visuals" which can be disabled in the "PlusPlus" settings dialog.

      The new feature highlights all known user objects using a text foreground color of the selected "Random Bookmark" background color. So I guess that you've defined a background color for "Random Bookmark" that is (close to) "black" and therefore the highlighted table name "disappears". If you disconnect the object cache is flushed and therefore the highlighting does not occur.

      Currently I haven't created separate color selections for the new highlighting since I was focusing on the core functionality, therefore these "strange" links from some background color to some other text foreground color.

      The details about the new highlighting can be found on the SQLTools++ homepage:

      http://www.sqltools-plusplus.org:7676/sqltools_pp.html

      It describes in the "Changelog" section in detail which colors are used for what kind of new highlighting.

      Anyway, if you don't like it you can just disable the whole new stuff in the "PlusPlus" settings.

      Regards,
      Randolf

       
    • Hi Randolf,

      I'd disabled the highlight setting and now it's working.

      Thanks,
      Alexandre Tarquino