#1 Missing prerequisites

closed-fixed
Grant McLean
None
5
2005-06-24
2005-06-24
Dan Boorstein
No

I had to install the following from CPAN in order to
not fail any tests. My perl install is a default gentoo
build.

Imager
Template::Toolkit
Lib::XML
Apache::LogRegex

Discussion

  • Grant McLean
    Grant McLean
    2005-06-24

    Logged In: YES
    user_id=242694

    Thanks very much for the feedback Dan. The problem is now
    fixed in CVS and will be in a release version within a few days.

    The test scripts were set up to skip tests requiring modules
    which weren't installed. Unfortunately, I accidently
    included t/01_require_all.t in the distribution - it was
    only ever intended to be in CVS.

    The modules you listed are not really prerequisites of Sprog
    although obviously without them some of the gears won't
    work. Eventually there will be gears wrapping lots of CPAN
    modules and I don't want to require someone to install half
    of CPAN just to install Sprog.

     
  • Grant McLean
    Grant McLean
    2005-06-24

    • assigned_to: nobody --> grantm
    • status: open --> closed-fixed