Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#86 login problems

0.8.1
closed
nabber00
login (1)
5
2014-02-23
2014-02-21
wil
No

I installed the 8.1 and it worked ok, then i noticed that since 2013 you have updated some files, I than took them from the TRUNK (https://sourceforge.net/p/sphpblog/svn/HEAD/tree/) and installed. Now when logging in (i left the config,images and content folder from before) it says "SUCCESS" but clicking on anything will bring the index.php main page and logged out. BAMMMM.
I than reinstalled it from scratch and has the same login/out prob
I put back the 8.1 (ver. july 2012) and it works perfectly.
I checked the files you modified up to the 2 Feb 2014 and it seams you made some good upgrades on meta and automatic logout ...... maybe the prob is there ....

Is anything I can mod my self to make it work? i.e.: recourse (//) all the lines in the various files with the automatic logout time?

For now I'll put back the 8.1, but I would b very happy to try any beta file on my server.

thx

Discussion

  • nabber00
    nabber00
    2014-02-21

    • status: open --> accepted
     
  • nabber00
    nabber00
    2014-02-21

    Yes I think you've nailed it. This should all be fixed in trunk. I've been having similar issues with my test install so I haven't made a new release yet but I guess at this point it can't hurt since worst case it would have a similar problem. I really expect a fresh install will work fine. I'll put out a new release shortly.

     
  • nabber00
    nabber00
    2014-02-21

    • status: accepted --> closed
    • assigned_to: nabber00
     
  • nabber00
    nabber00
    2014-02-21

    I just released 0.8.2 a few minutes ago, hopefully that works better.

     
  • wil
    wil
    2014-02-21

    thx, ur magic, i'll try it on tomorrow

     
  • wil
    wil
    2014-02-22

    nope,login working but then returning to home logged out, i recourse the time for automatic logout but still the same ....maybe i did not find all the files, or maybe is the cookie...... let me know pls

     
  • wil
    wil
    2014-02-22

    removed

     
    Last edit: wil 2014-02-22
  • nabber00
    nabber00
    2014-02-22

    • status: closed --> accepted
     
  • nabber00
    nabber00
    2014-02-22

    • status: accepted --> closed
     
  • nabber00
    nabber00
    2014-02-22

    I fixed it in svn r272, looks like it was something with the session regenerate id function. A new release will be out shortly.

     
  • wil
    wil
    2014-02-23

    just tested, login its working all the way now, THANK YOU, I ll test the rest tomorrow.

    .... I removed the scripts above, i realise that if I want to mod something I should push my brain and my time, .... but if u think it can b usefull to someone I ll put it back (it makes folders and sub for respective year>month>day> and generate a simple txt file in them with all the clients info, very usefull to track ppl behaviour in the site

    wil