Timeout, lose blog entry

2011-03-11
2013-06-03
  • Chris Thompson
    Chris Thompson
    2011-03-11

    I have found that the login times out and I only find out when I hit "preview" or "post" on a blog entry.  Once I log in, the entry is lost, despite a message that tells me it has been saved.  I'm using Google Chrome as the browser if that makes a difference.  Is this a known bug?  I presume the draft should have been saved.  I also can't get to it with the back button.

    Otherwise is there a way to turn the timeout off?  I cant find it in the settings.

     
  • nabber00
    nabber00
    2011-03-11

    The timeout is a PHP setting.  The default is 24 minutes I think.  Check out your php.ini file or phpinfo() results.

    Restoring the draft should work so long as you have cookies enabled.

     
  • Chris Thompson
    Chris Thompson
    2011-03-11

    I don't think I have access to the php.ini file.  I ran phpinfo() and the ini file is in /usr/local/lib, so only my hosting provider can change it.  Is there a local directory I can put a copy in just for my site?

    I can't restore the draft.  Once it has timed out and I log in I get the link "click here to restore your draft" or similar, but just a blank form is then displayed.  Anything typed before is lost forever.  That makes the blog software very fragile.  A race against the clock to make the entry before you lose it when you hit save.  Or I need to copy/paste each entry out to notepad before I hit preview/post.  Which would be a drag.  Any thoughts?

     
  • nabber00
    nabber00
    2011-03-13

    You should be able to do something like ini_set(''session.gc_maxlifetime", $var); where $var is the number of seconds you want for the login timeout.  Default is 1440.  Probably the best place for that is in the scripts/config.php file somewhere.  But if your server is running Debian that may not work.

    Again, if you have cookies turned off in your browser the restore feature isn't going to work.  Please check that.  Or see what happens when you use another browser, I use Firefox without a problem.  I've done some testing with IE too.

    Also remember that as long as you click preview before 24 minutes is up, it will restart the clock and give you another 24 minutes.