#44 Compiling On Ubuntu 11.10 Raises Dependecy Problems

open
Peter Grasch
simon (7)
5
2013-01-13
2012-02-16
user2037
No

Installing on Ubuntu 11.10 fails as follows:

http://simon-listens.org/wiki/index.php/Development_Environment#Linux

sudo apt-get install git-core build-essential cmake bison flex gettext gettext-kde kdeartwork kdelibs5-dev libxtst-dev libqt4-sql-sqlite qtmobility-dev libphonon-dev libattica-dev libattica0 zlib1g-dev portaudio19-dev

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
portaudio19-dev : Depends: libjack-dev
E: Unable to correct problems, you have held broken packages.

Adding libjack-dev:

The following packages have unmet dependencies:
libjack-dev : Depends: libjack0 (= 1:0.121.0+svn4469-2ubuntu2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Discussion

  • user2037
    user2037
    2012-02-16

    Trying to compile Master: Git rev d14f09480ee4dc03c45e0a84186975f9e35dd56d

     
  • Peter Grasch
    Peter Grasch
    2012-02-19

    Hi!

    Sorry, the wiki is a bit out of date. I updated it now with what I think should work but I don't have a system here to test the instructions with.

    Please let me know if everything is okay.

    Btw.: We have moved to KDE. Please use the KDE bugtracker (https://bugs.kde.org/) for future tickets. Thanks.