Is Tcl/Tk 8.0 OK as minimum?

  • I am very tempted to making the minmum Tcl/Tk version 8.0 for future releases of SpecTcl. How do you feel about that?

    The only real problem I can see is for people with old hardware and/or OS'es, where compiling is a big burden. For people who just use older versions anyway (to be compattible with the rest of their software), one can easily have several versions of Tcl/Tk running at the same time.

    The reason that I want to do this is that firstly, the oldest version of Tcl/Tk I have is 8.0, so it would be irritating to have to check older versions. The second is that I think the namespace functionality will come in very handy with a program of this size.


    • I wouldn't mind at all, especially if it makes your work more productive and if it makes it easier to do a better job. Development wise, I expect 8.0+ to be much more important. But I recommend posting your inquiry to comp.lang.tcl.