#86 Ctrl+C is ignored for length of buffer

closed-fixed
nobody
None
5
2007-09-08
2007-07-19
Reuben Thomas
No

With the default buffer size and typical sample rates, this doesn't matter. But to play audio from the internet I use a much larger buffer (e.g. 256Kb), and this can result in several seconds before my Ctrl+C is noticed.

Discussion

  • Reuben Thomas
    Reuben Thomas
    2007-08-23

    Logged In: YES
    user_id=50145
    Originator: YES

    Fixed in CVS.

     
  • Reuben Thomas
    Reuben Thomas
    2007-08-23

    • status: open --> closed-fixed
     
  • Reuben Thomas
    Reuben Thomas
    2007-09-08

    Logged In: YES
    user_id=50145
    Originator: YES

    My fix didn't work, as it broke all sorts of other things, and had to be reverted. The problem is detecting the requested break while in various loops and breaking out while cleaning up properly.

     
  • Reuben Thomas
    Reuben Thomas
    2007-09-08

    • status: closed-fixed --> open
     
  • Reuben Thomas
    Reuben Thomas
    2007-09-08

    Logged In: YES
    user_id=50145
    Originator: YES

    Oddly, this does seem to work fine after all. Closing again.

     
  • Reuben Thomas
    Reuben Thomas
    2007-09-08

    • status: open --> closed-fixed