#70 WS-I Test Tool Integration

v1.0 (example)
closed
nobody
general (369)
5
2006-11-06
2006-10-18
daschae
No

Ignore 1579754

I am receiving a failure during WS-I compliance testing
when a wsdl is validated from within soapUI. If I run
the validation from the Analyzer command within the
WS-I test tools everything turns out ok. The issue
appears to be with the way that soapUI is tracking
imported schema files. We have schemas with the same
name under different directory locations with different
content, soapUI appears to be replacing items with the
same name when it loads schemas from other locations.
For example if foo/bar/Components.xsd is loaded first
when we load ach/foo/bar/Components.xsd later it
overwrites Components.xsd from the perspective of
soapUI rather than keeping both. I've attached a zip
file containing an example wsdl and the schema
components (I've validated all of the schemas, and run
the WS-I tools from the command line and all point to
things being OK, only soapUI kicks back a validation
fault via the WS-I test tools).

Discussion

  • Ole Lensmar
    Ole Lensmar
    2006-10-18

    Logged In: YES
    user_id=838515

    Thanks!

    Could you please try this with Caching of WSDL's turned off?

    please attach the zip or mail it to ole@eviware.com

    regards,

    /Ole

     
  • daschae
    daschae
    2006-10-18

    Logged In: YES
    user_id=1103443

    I tried with WSDL caching disabled and got the same result.

     
  • Ole Lensmar
    Ole Lensmar
    2006-10-18

    Logged In: YES
    user_id=838515

    ok thanks.. please mail me your zip and I will look into
    this later tonight..

    regards!

    /Ole

     
  • Ole Lensmar
    Ole Lensmar
    2006-10-18

    Logged In: YES
    user_id=838515

    ok.. this was due to a bug in the internal schema exporter
    which did not handle this situation.. its working ok over
    here now and I'll try to release a new snapshot by the end
    of the week..

    thanks for the report!

    /Ole
    eviware.com

     
  • Ole Lensmar
    Ole Lensmar
    2006-10-22

    • status: open --> pending
     
  • Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending --> closed