SOAP::Lite version 0.710.08 regressed?

Help
Tim C
2009-11-06
2013-05-09
  • Tim C
    Tim C
    2009-11-06

    Did SOAP::Lite version 0.710.08 regress?

    I have a small SOAP::Lite client I've been running for about a week, and in the process of trying to get attachments working, I upgraded to SOAP:Lite 0.710.08 and Perl 5.10.1 (ActiveState ppm, Windows XP) . Now my program has stopped working and I get a bunch of errors in the console. I have tried several variations of ppms for SOAP::Lite. I am wondering of other folks have run into this same problem.

    <blockcode>
    Subroutine SOAP::Lite::Deserializer::XMLSchemaSOAP1_2::as_dateTime redefined at C:/Perl/site/lib/SO +AP/Lite/Deserializer/XMLSchemaSOAP1_2.pm line 20.
    Subroutine SOAP::Lite::Deserializer::XMLSchema2001::as_dateTime redefined at C:/Perl/site/lib/SOAP/ +Lite/Deserializer/XMLSchema2001.pm line 29.
    Use of uninitialized value $_ in pattern match (m//) at C:/Perl/site/lib/SOAP/Lite.pm line 343.
    Use of uninitialized value in sprintf at C:/Perl/site/lib/SOAP/Lite.pm line 3481.
    Use of uninitialized value $_ in pattern match (m//) at C:/Perl/site/lib/SOAP/Lite.pm line 343.
    Use of uninitialized value in sprintf at C:/Perl/site/lib/SOAP/Lite.pm line 3481.
    Use of uninitialized value $_ in pattern match (m//) at C:/Perl/site/lib/SOAP/Lite.pm line 343.
    Use of uninitialized value in sprintf at C:/Perl/site/lib/SOAP/Lite.pm line 3481.
    A fault (axis2ns17:Client) occurred: The endpoint reference (EPR) for the Operation not found is ht +tps://localhost:9843/services/LoginService and the WSA Action = testNamespace:loginUsingUserCreden +tial#

    </blockcode>

     
  • Tim C
    Tim C
    2009-11-06

    It seems that upgrading Perl and the rest of the modules revealed a bug in my test program.  My apologies.