#151 CPANTS says META.yml broken

0.71
closed-fixed
Martin Kutter
Packaging (7)
5
2008-06-28
2008-06-28
Martin Kutter
No

metayml_has_license not ok

Error: This distribution does not have a license defined in META.yml.

Remedy: Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

metayml_conforms_to_known_spec not ok

Error: META.yml does not conform to any recognised META.yml Spec. See 'metayml' in the dist error view for more info.

Remedy: Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-current.html and change your META.yml accordingly

Error Message: 1.3, Missing mandatory field, 'author' (author) [Validation: 1.3], Missing mandatory field, 'license' (license) [Validation: 1.3], Missing mandatory field, 'abstract' (abstract) [Validation: 1.3], Expected a list structure (author) [Validation: 1.3], License '' is unknown (license) [Validation: 1.3], value is an undefined string (abstract) [Validation: 1.3]

Discussion

  • Martin Kutter
    Martin Kutter
    2008-06-28

    • status: open --> closed-fixed