#16 SOAP1.2 support

2.1x
open
nobody
SOAP Client (9)
3
2007-09-27
2007-09-27
Martin Kutter
No

SOAP1.2 is the actual standard, while 1.1 is still the more popular protocol

SOAP::WSDL should support both.

Steps needed are:

* Data Classes
- implement a SOAP1.2 Fault class
* Code Generator
- Typemap
- change to include either 1.1 or 1.2 typemap
* MessageParser
- Check for SOAP1.2 instead of SOAP1.1 namespaces

Discussion