missing dependencies

Rich Rath
  • Rich Rath
    Rich Rath

    Hi, running Mint debian edition and looking to install smasher. 
    When I try from the sourceforge deb file, I get

    Error: Dependency is not satisfiable: libcsound64-5.1

    .  I have both the executable and the headers (dev) packages installed, but the repos use libcsound64-5.2.
    This seems to me to be my best bet, as it would just need something in the code to accept the 5.2  version of csound, not just the 5.1.

    When I try building from sourceforge source,  I get the following error from ./configure:

    checking wxWidgets version... 2.8.12
    ./configure: line 3349: syntax error near unexpected token `SNDFILE,'
    ./configure: line 3349: `PKG_CHECK_MODULES(SNDFILE, sndfile >= 1.0.2, ac_cv_sndfile=1, ac_cv_sndfile=0)'

    When I try to install from autostatic's deb, it installs fine with gDebi, but won't run.  running smasher from CL yields:

    smasher: error while loading shared libraries: libwx_gtk2u_media-2.8.so.0: cannot open shared object file: No such file or directory

    This one seems like I would need to compile wxwidgets with a flag to enable wxMediaCtrl, but the current source was using for wxwidgets does not list  -enable-mediactrl as an option in the config help and bug reports seem to indicate that this was just dropped from the code at some point..  I downloaded and tried to build wxgtk anyway, but had no luck there.

    I managed to get smasher installed on my laptop and really like it.  It would be great if someone could help me get it running on my desktop too.  Thanks.

  • I've repackaged Smasher and uploaded it to both the KXStudio-team repository and my own repository. It works for me with Ubuntu 12.04.