Dependencies on Ubuntu 10.04 (64 bit)

Help
Péter
2010-07-30
2013-04-24
  • Péter
    Péter
    2010-07-30

    Hi!
    I've just compiled Smasher on Ubuntu Studio 10.04 (64 bit). I ran into some dependency problems first, it seems like .configure doesn't check for the following dependencies:

    g++
    libmad0-dev
    libcsound64-dev
    libgstreamer0.10-dev
    libgstreamer-plugins-base0.10-dev

    Also, automake and libtool were needed to run autogen.sh

    Maybe this is newb stuff but I think it would be nice if these dependencies were made clear in INSTALL and also that .configure would check for them. The errors thrown by make aren't always very easy to understand.

    Now it seems to work though, and I really, REALLY like your app so far! Thanks :)

     
  • e loeliger
    e loeliger
    2010-08-15

    Hi medvind,

    Many thanks for your help!

    I meant to do that myself a while ago, but I'm just really busy finishing uni at the moment. I'll look into it in September.

    -Esther

     
  • Péter
    Péter
    2010-08-15

    Hi again!
    No problems! Good luck with uni :)

    /Péter