Bruce,

The only way the 3ware driver ioctl routine returns errno = -EIO to userspace
is when you get a timeout (No response interrupt for a command for 60 seconds)
on the ioctl interface.

It would also be accompanied by this printk in the driver:

rintk(KERN_WARNING "3w-9xxx: scsi%d: WARNING: (0x%02X:0x%04X): Character ioctl (0x%x)
timed out, resetting card.tw_dev->host->host_no, TW_DRIVER, 0x37,
                               cmd);

Do we see the above printk in the /var/log/messages or dmesg ?

I am going to try to reproduce this.

-Adam

-----Original Message-----
From: Bruce Allen [mailto:ballen@gravity.phys.uwm.edu]
Sent: Thu 9/27/2007 9:19 PM
To: Adam Radford; Gabor Kovacs
Cc: Smartmontools Mailing List; gbakos@cfa.harvard.edu
Subject: Re: [smartmontools-support] Hitachi disks SMART offline test command returns error

Hi Adam,

Any thoughts about this?  New bug report below, old bug report is here:
http://osdir.com/ml/utilities.smartmontools/2005-06/msg00016.html

Looks like a specific drive + 3ware 9500 controller tickles this bug.

Cheers,
        Bruce


On Wed, 26 Sep 2007, Gabor Kovacs wrote:

> Hi All,
>
> I would like to reopen an issue that was posted as
> "execute Short Self-Test failed" on 3ware/Hitachi, Cowley, David E,
> 2005/06/14.
>
> The problem still exists, initiating an offline test returns error, but drive
> actually begins testing. It is linked somehow to this Hitachi-3ware
> combination, as same model 3ware controller with Seagate ST3300831AS drives
> works fine. Should be a 3ware problem? Any idea?
>
> Thanks
> Gabor Kovacs
> ------
> Model Family:     Hitachi Deskstar 7K500 series
> Device Model:     HDS725050KLA360
>
> [root@hat ~]# smartctl -t short -d 3ware,0 /dev/twa1
> smartctl version 5.37 [x86_64-redhat-linux-gnu] Copyright (C) 2002-6 Bruce
> Allen
> Home page is http://smartmontools.sourceforge.net/
>
> === START OF OFFLINE IMMEDIATE AND SELF-TEST SECTION ===
> Sending command: "Execute SMART Short self-test routine immediately in
> off-line mode".
> Command "Execute SMART Short self-test routine immediately in off-line mode"
> failed: Input/output error
>
> However:
> --------------
> [root@hat ~]# smartctl -a -d 3ware,0 /dev/twa1
> ...
> Self-test execution status:      ( 247) Self-test routine in progress...
>                                        70% of test remaining.
> ...
>
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> Smartmontools-support mailing list
> Smartmontools-support@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/smartmontools-support
>


CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and contains information that is confidential and proprietary to Applied Micro Circuits Corporation or its subsidiaries. It is to be used solely for the purpose of furthering the parties' business relationship. All unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.