Hi Alex,

thanks for your prompt reply!

with '-d sat' I have less success:

---------------------
/ # smartctl /dev/sda -d sat -H
smartctl 6.1 2013-03-16 r3800 [mips-linux-2.6.12.6-VENUS] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported scsi opcode

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
/ # smartctl /dev/sda -d sat -H -T verypermissive
smartctl 6.1 2013-03-16 r3800 [mips-linux-2.6.12.6-VENUS] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported scsi opcode

SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't show if SMART supported.
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't show if SMART is enabled.
                  Checking to be sure by trying SMART RETURN STATUS command.
SMART support is: Unknown - Try option -s with argument 'on' to enable it.Read SMART Data failed: scsi error unsupported scsi opcode

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: UNKNOWN!
SMART Status, Attributes and Thresholds cannot be read.

/ # ls -al /dev/sda*
lr-xr-xr-x 1 root root 33 1970-01-01 00:00 /dev/sda -> scsi/host0/bus0/target0/lun0/disc
lr-xr-xr-x 1 root root 34 1970-01-01 00:00 /dev/sda1 -> scsi/host0/bus0/target0/lun0/part1
lr-xr-xr-x 1 root root 34 1970-01-01 00:00 /dev/sda2 -> scsi/host0/bus0/target0/lun0/part2
lr-xr-xr-x 1 root root 34 1970-01-01 00:00 /dev/sda3 -> scsi/host0/bus0/target0/lun0/part3



On Mon, Jun 17, 2013 at 5:13 PM, Alex Samorukov <ml@os2.kiev.ua> wrote:
On 06/17/2013 12:02 PM, Sergey Talchuk wrote:
Hi All,

trying to get smartmontools working on my platform. It looks like the embedded sata controller is not supported. Could someone help please?

Thank you in advance!

----------------------------
Smartmontools: 6.1
HDD: WDC WD20EARX-00P
OS: Linux 2.6.12 (embedded, uClibc 0.9.28)
CPU: Realtek Venus, mipsel
Board: Realtek RTD1073DD

-http://www.hwp.ru/Multimedia/Iconbit.hds7l/images/Iconbit_HDs7l_7.jpg
-http://www.ixbt.com/multimedia/iconbit-hds6l-hds7l/6l/07-big.jpg


/ # smartctl /dev/sda -d scsi -H
As far as i could see - you are trying to use SCSI device with SATA. Try to run smartctl with -d sat.