Hello,

I am not able to find out the SMART info for the hard drives on my friend's system. It's not working for both drives, so it looks like a driver or smartmontools issue. Please find the details below:
------
cat /proc/scsi/sg/device_strs
ATA             ST3120026AS             3.18
ATA             WDC WD1600JS-55M        10.0
-------
smartctl -a /dev/sdb
smartctl version 5.37 [i686-pc-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/


Probable ATA device behind a SAT layer
Try an additional '-d ata' or '-d sat' argument.
------
smartctl -a -d ata /dev/sdb
smartctl version 5.37 [i686-pc-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Smartctl: Device Read Identity Failed (not an ATA/ATAPI device)

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
------
smartctl -a -d sat /dev/sdb
smartctl version 5.37 [i686-pc-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Smartctl: Device Read Identity Failed (not an ATA/ATAPI device)

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
------
smartctl -a -d scsi /dev/sdb
smartctl version 5.37 [i686-pc-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Serial number:      WD-WCANM5351253
Device type: disk
Local Time is: Sat Apr 14 17:16:22 2007 EDT
Device does not support SMART

Error Counter logging not supported

[GLTSD (Global Logging Target Save Disable) set. Enable Save with '-S on']
Device does not support Self Test logging
-------

The above commands give the same ouput with the other HD as well. Kernel version is 2.6.11.7. Could anyone please tell me how can I get this fixed? Thanks!