Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Problem Loading Data (Phillips Respironics)

2012-10-25
2014-04-19
1 2 > >> (Page 1 of 2)
  • Alan Holcomb
    Alan Holcomb
    2012-10-25

    I'm having an issue getting data to load from my Phillips Respironics System One.
    The app reads and recognizes the machine make and model but none of the data seems to be importing?
    (Running on Win7)
    Help?

     
  • Terry Anderson
    Terry Anderson
    2012-10-26

    I'm surprised someone didn't answer this sooner.  You probably have a 60 series CPAP.  The present version of SleepyHead will not read our data.  There is a patch but it takes some skill to use.  I am trying to get one of the 'developers' in this forum to patch it and attach the new .exe to this thread.  Keep monitoring this forum for news.  This has been an issue for MONTHS.

     
  • I built a Windows EXE based on my branch which should support the series 60.  You can download it at:
    https://s3.amazonaws.com/thefreemanclan.net-publish/SleepyHead.zip

    You should just need to replace the SleepyHead.exe in your install directory for it to work, but I can't be certain of that.

    I don't know how it will behave in terms of auto-updates.  It might refuse to download future updates, or it might re-download the standard version and overwrite itself.  If the latter happens I can probably disable updates in it, or you can do so in configuration. 

    I'm interested in feedback RE how it works.  I couldn't find any documentation on how the Windows installers are packaged so beyond compiling it I'm just winging it.

     
  • Terry Anderson
    Terry Anderson
    2012-10-27

    THANK YOU.  I downloaded from your link, opened the zip file, copied the exe to the C:\Program Flies (x86)/SleepyHead folder (where version 9.2-1 was installed) - it loaded the data without incident.  What a wealth of information!  I am running a Win7 64-bit system.  I will post any problems after I study all these charts and graphs.  I wouldn't worry too much about updates - I'll watch for the next official version that includes the 60 series update and reinstall.  For right now, its great.  Thanks again.

     
  • That is good to hear!  Keary Griffin provided the series 60 patch.  We should probably get the news out that this appears to work.

     
  • Alan Holcomb
    Alan Holcomb
    2012-10-27

    Thank you Rich0.
    Works fine for me as well, just copied the exe into the program folder.

     

  • Anonymous
    2012-10-29

    Thank you.  This worked for my 460P

     
  • Paul
    Paul
    2012-11-05

    Thanks it works with my new System One RemStar Auto with A-Flex (561P)

     
  • For OSX there is now:
    https://s3.amazonaws.com/thefreemanclan.net-publish/SleepyHead.dmg

    Again, feedback welcome.

     
    • Chris Bredesen
      Chris Bredesen
      2013-06-10

      First - thanks very much for making this software!

      Second - I'm running the build posted above (2012-11-05) on OS X 10.8.4 and with my 260P unit. I still cannot import any data. I have tried removing the ~/Documents/SleepyHeadData and starting from scratch. Still nothing. There is definitely data on my card. I get the model/serial info along with "No CPAP Machine Data Imported". Software reports "System One (260P)"

      Any ideas? I'd be happy to help diagnose technical issues, I am a software engineer though not too familiar with Qt/C/C++....

       
  • Charles R
    Charles R
    2012-11-05

    I downloaded the new .dmg file.  I deleted the existing SH application from the Applications folder.  I opened the new .dmg file and drug the new SH file to the Applications folder.

    It appears to work without problems.  The new SH version number is 0.9.2-3.  Thank you for this patch.

     
  • Sergei
    Sergei
    2012-11-07

    Thanks it works with System One RemStar Auto with A-Flex (560P). (Windows 64)

     
  • dwp
    dwp
    2012-11-30

    Man you guys are awesome…Was having issues importing from my Respironics 560P into SH, then found this site and thread. Much appreciated guys…Works like a champ with the patch.

     

  • Anonymous
    2012-12-09

    I have the same problem, except I don't use either windows or macosx. I downloaded the linux package (rpm) from the download section, and it runs nice, but won't import data. The deb package (unpacked with ar) and the Fedora installer packaged binaries won't even run (missing libqtwebkit libraries, and I don't see a quick way of fixing that  - rpm dependency hell). I see a patch in the bugs section, but I can't find the source code anywhere..?! Can someone please point me to the source code, or maybe even build me a statically linked rpm with that patch applied? Thanks.

    For reference, this is the bug that describes my problem:
    http://sourceforge.net/tracker/?func=detail&aid=3508907&group_id=513997&atid=2089181

     
  • You can download linux source including the patch from:
    git://github.com/rich0/rich0-sleepyhead.git

    The branch rich-test contains the prs1 importer patches. 

    If you need me to build you a static binary let me know. 

     
  • Kyle Stewart
    Kyle Stewart
    2012-12-20

    I have Mac OSX 10.5.8.  Every time I try to start SH, I get the dialog box "The Application SleepyHead quit unexpectedly."  I am using the new SH version number is 0.9.2-3.  I could not get the prior version to load from my SD card.  My machine is a Philips Respironics System One RemStar Auto with A-Flex (560P).  Any help would be greatly appreciated.  I am not familiar with this process of building the app from source so I would need a dmg file.  Thanks.

     
  • Steve Pinkston
    Steve Pinkston
    2013-01-08

    I'm re-posting this from the Help forum - this one seems a bit more active.

    Since we got our new PR System One BiPAP (firmware 3.0) we had not been able to import data to SleepyHead. Over in the CPAP.com forum, I was referred to a patch published at:

    https://s3.amazonaws.com/thefreemanclan.net-publish/SleepyHead.zip

    I think this is rich0 's patch.

    I applied this (replaced the original sleepyhead.exe file), and now we are seeing SOME data (Usage and Session Times, for example), but some other data is missing or apparently corrupted.

    In Overview:

    AHI numbers have jumped to crazy huge values. Previously they were in the range of 5-12. Now they range from 150 to 800!

    Flow Limit, Pressure, Total Leaks, % in PB, and Peak AHI are all missing.

    In Daily:

    AHI, Pressure, and Leak are missing.

    We have an appointment with my wife's pulmonologist in a couple of days, and I'd like to be able to show him the SleepyHead data, but now I don't trust it.

    I'd be happy to share SD card contents with a developer if would help resolve this!

     
  • Yup, the 60-series BiPap apparently doesn't quite work yet.  It is my next priority (well, that and the fact that the program crashes every time I run it now and appears to be doing so for more and more linux users by the month).

     
  • Steve Pinkston
    Steve Pinkston
    2013-01-11

    I was able to get a copy of Encore Basic from one of the nice folks over on the CPAPtalk.com forum, and it reads the 60-series chip data just fine (interestingly, it identifies the machine as 'classic', so perhaps they've gone back to an older data format). Encore Basic doesn't provide the long-term charts that SleepyHead does (over a year in our case), but it does a good job on the details for the limited time that exists on the chip. The patch from rich0 does map the nightly usage correctly, so we'll keep using it for that alone.

     
  • ArizonaJon
    ArizonaJon
    2013-01-11

    I just downloaded the revised exe and installed.  Now my Philips Respironics 560P data loads and displays perfectly.  Using Windows 7, 64 Bit.  The software continues to read my wife's data from a BiFlex 750P.  Thanks so much.  The detailed data tells so much more than the average information that the machine gives. 

     
  • Steve Pinkston
    Steve Pinkston
    2013-01-16

    @ArizonaJon, which revised exe is that? Is it the same one I referred to in my 2013-01-08 post in this thread? I'm also using Win7-64 (and Win7-32 on another PC), but I'm having the issues I mentioned in that post, which you don't seem to be having.

     
  • kano62
    kano62
    2013-05-13

    I have just posted about not being able to read my 60 series data, until I read this thread and found that it works really well. Thanks for the update to include this series of PRS. The Encore Viewer is not as interactive as Sleepyhead and I regret getting it out of desperation. Well done guys...hats off to you!!

     
  • ArizonaJon
    ArizonaJon
    2013-05-23

    My wife's BiPap was just replaced with a Philips Respironics System One RemStar BiPAP Auto with Bi-Flex (760P), firmware version 3.03. The data on AHI, Pressure, Leak and Snore are no longer working. The AHI shows a very high number - not correct - and the other show no data. Data on Resp. Rate, Flow Rate and others seem to be OK. Using version v0.9.2-3 (beta) with a build date of Jan 9 2013. FYI, this build works perfectly on my Philips Respironics system One RemStar Auto with A-Flex (560P), firmware version 3.02. Any help with the 760P issue would be appreciated. I can supply a copy of the data if that will help. This software has been great at helping us understand what is happening with out sleep apnea. Thanks for the support.

     
1 2 > >> (Page 1 of 2)