Cannot See "Office Communicator" plugin listed within Pidgin after installing latest sipe plugin/package

Carson N
  • Carson N
    Carson N

    I've tried multiple times with different instructions from the web on installing pidgin first and then downloading/installing the latest sipe package. Can someone please help me with this?

    FYI - i have it working on my previous box which is windows xp but we're migrating to new machines at work and can't seem to get it working (showing up as an option in Pidgin when adding an account)

    I'm on Windows 7 Enterprise edition now. Please help. I can provide contact info if it's easier and we can do a remote/shared session if needed via

    Thanks in advance,

  • Stefan Becker
    Stefan Becker

    Please try this:

    • download and run Windows Pidgin installer (this should install version 2.10.7)
    • download and run SIPE 1.15.1 for Windows

    Open an Explorer window and browse into the Pidgin installation directory and then to the plugins subdirectory. Do you see a file libsipe.dll there? If not, then the installation has failed. I would search the harddisk for libsipe.dll and move the files to the correct location by hand.

    If the file is there then open a command window and enter

     ... path to ...\pidgin\pidgin.exe --debug >pidgin_debug.log 2>&1

    Close Pidgin again and open pidgin_debug.log with an editor. If Pidgin has found and successfully loaded SIPE then you should see the following lines

     (...) plugins: ....\pidgin\plugins\libsipe.dll
     (...) sipe: bindtextdomain = ....
     (...) sipe: bind_textdomain_locale = ....
     (...) sipe: NSS initialised

    If you don't see this then Pidgin can't load libsipe.dll. In this case you have probably a duplicate DLL in your path that conflicts with a DLL from the Pidgin installation.

    Last edit: Stefan Becker 2013-04-11
  • Azuvector

    Had the exact same problem as Carson N.

    Debug logs include the following lines relating to SIPE:
    (15:53:19) plugins: probing C:\Program Files (x86)\Pidgin\plugins\libsipe.dll
    (15:53:19) plugins: C:\Program Files (x86)\Pidgin\plugins\libsipe.dll is not loadable: `C:\Program Files (x86)\Pidgin\plugins\libsipe.dll': The specified module could not be found.

    I have no other libsipe.dll file on my harddrive. Windows 7 Professional 64bit.
    Problem turned out to simply be that I was running Pidgin 2.10.2 instead of 2.10.7.
    Easy fix. Posting for future quick fixes for anyone googling this. (Would be nice if Pidgin gave a version mismatch error message or something.)