Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

pidgin-sipe plugin against pidgin 3.0.0 on Windows ?

Help
2013-12-15
2013-12-19
  • Artur Kudelka
    Artur Kudelka
    2013-12-15

    Hello,
    please, is it possible to compile pidgin-sipe plugin against pidgin 3.0.0
    on Windows ?

    I compile pidgin with mingw gcc 4.8 without problem,
    but when I try to compile pidgin-sipe, I got:

    checking that sizeof(uuid_t) is 16... configure: error: in
    `/cygdrive/D/devel/pidgin-devel/pidgin-sipe-1.17.3':
    configure: error: sizeof(uuid_t) is not 16

    Please notify the SIPE developers.

    Copy & paste all lines starting with the line

    checking that sizeof(uuid_t) is 16...

    to the report and attach the file "config.log".

    Compiler information:

    host: i686-pc-cygwin
    build: i686-pc-cygwin
    compiler: gcc

    See `config.log' for more details

    Do I have a badl enviroment or compiler ?

    Thank you in advance for response.

    Br
    Artur

     
    • Stefan Becker
      Stefan Becker
      2013-12-16

      I just spent some time to do some "easy" cleanups for 3.x.x API compatibility. It's still not looking good: 130+ compilation errors remaining. I also found a regression in the 3.x.x API.

       
  • Stefan Becker
    Stefan Becker
    2013-12-15

    No, it's not possible, at least at the moment. The 3.x.x API is changing all the time and we developers are out of the loop on those changes, as the Pidgin project does not support third-party plugins.

    I tried myself yesterday and the API has changed considerably since the last time I tried. It will require lots of changes to the libpurple backend to get it to compile cleanly against the 3.x.x API again.

     
  • Stefan Becker
    Stefan Becker
    2013-12-17

    I fixed all the easy problems in git HEAD. But there are still a few problems left that need more detailed analysis.

     
    • Artur Kudelka
      Artur Kudelka
      2013-12-18

      Hello Stefan,
      it sounds good. Thank you for your work and information.

      Do you think it would be possible to use audio/voice on Windows with
      pidgin-sipe ?

      Br
      Artur

      2013/12/17 Stefan Becker stefanb2@users.sf.net

      I fixed all the easy problems in git HEAD. But there are still a few
      problems left that need more detailed analysis.


      pidgin-sipe plugin against pidgin 3.0.0 on Windows ?https://sourceforge.net/p/sipe/discussion/688534/thread/09b04d15/?limit=25#af38

      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/sipe/discussion/688534/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
      • Stefan Becker
        Stefan Becker
        2013-12-19

        As far as I understood gstreamer/farstreamer is now working on Pidgin 3.0.0 and Windows. SIPE requires also libnice.

        Are you using configure or Makefile.mingw? With configure you can check if HAVE_VV is defined in config.h. Makefile.mingw does not support V&V without changes.