SimpleTest 1.0.1 released

Hi...

Probably the longest point release in history, but it's here. This is the last version that supports PHP 4.

Compared to the 1.0 version, there is much better PHP 5 support (all the way up to PHP 5.3) as long as E_STRICT is not enabled. The mocks support type hinting and interface mocking, the whole system properly supports exceptions and there are many small improvements to the web browser.

Apart from some obscure differences, tests written for the 1.0 release should work fine in the 1.0.1 version.

Many thanks to all the developers, patch contributers, commenters, naggers (especially Perrick) who helped.

yours, Marcus

Posted by Marcus Baker 2008-04-08