#7 Conflict in libwnck version - Ubuntu Gutsy

open
nobody
None
5
2008-02-07
2008-02-07
Anonymous
No

Installed SimDock from .deb package simdock_1.2_i386.deb (dpkg -i), after installing libwnck*/libwnck*.dev from Gutsy repos (apt-get install).
SimDock does not work, apparently looking for an older version "libwnck-1.so.18", while Gutsy ships libwnck-1.so.22.
Workaround: simlink libwnck-1.so.22 => libwnck-1.so.18 in /usr/lib, then SimDock works fine...
Problem: Update manager doesn't work any more, claiming there are dependency conflicts, or giving the message "software index is broken"!
I cannot download any update from Update Manager!
Running "apt-get install -f" fixes the dep. conflict, But removes SimDock...!
Dariush

Discussion

  • Logged In: NO

    I also can confirm this. Is there an UPDATE to this that will support the Newer library so the system does not keep removing SIMDOCK?

     
  • Oxmosys
    Oxmosys
    2008-02-26

    Logged In: YES
    user_id=1932542
    Originator: NO

    This bug is fixed in latest Ubuntu Hardy alpha 5 which will be released in RC in two months.