Just as there have been recent changes checked in to
standardize the names of functions, there could be some
standardizing of variable names.
The reason for this is not to help with the readability
or maintainability of variables in ShUnit (this would
almost have the opposite effect), but to protect those
variables in ShUnit from being overwritten accidentally
by some calling script. The simple examples are TRUE
and FALSE. These might be renamed ShU_TRUE and
ShU_FALSE. Similar changes would be protect "global"
variables such as STR_ALL_TESTS and "local" variables
such as 'strMessage', 'boolResult', or (in the function
shuFileLineCount) 'count' .
Of course, renaming these variables to have a known,
documented prefix won't prevent some code from
accidentally overwriting them (or from having the
shUnit functions overwrite some caller's variable), but
it could help because it would provide a guide to users
of ShUnit for what variable names NOT to use (i.e.,
names that begin with some ShUnit prefix).