2011/11/4 nap <naparuba@gmail.com>


On Fri, Nov 4, 2011 at 3:11 PM, Gauthier DOUCHET <gauthier.douchet@gmail.com> wrote:
Hi,

I did a new install of shinken from git sources. I took the config of my existing shinken server which is working.

[...]


But I got this error for my hosts:
Info: /bin/sh: /check_ping: not found

If I replaced by : command_line    /usr/lib/nagios/plugins/check_ping -H $HOSTADDRESS$ -w 3000,20% -c 5000,50% -p 1, it's working.

I think I forgot to install or configure something on my new shinken install, but I'm guessing what... :)

Thank you for your help,
Regards,
Gauthier
Hi,

And is the problem still occurs with USER1 instead?
Can you also launch :
shinken-arbiter -v -c /etc/shinken/nagios.cfg -c /etc/shinken/shinken-specific.cfg
And see if your resources.cfg file is listed in loaded files?

Thanks,


Jean


------------------------------------------------------------------------------
RSA(R) Conference 2012
Save $700 by Nov 18
Register now
http://p.sf.net/sfu/rsa-sfdev2dev1
_______________________________________________
Shinken-devel mailing list
Shinken-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/shinken-devel


Hi,

After launching shinken-arbiter -v -c /etc/shinken/nagios.cfg -c /etc/shinken/shinken-specific.
cfg, I got:
 Processing object config file '/etc/shinken/resource.cfg' so yes I think it's launched.

I modified my config with user1:
 # Simple ping command
  define command {
    command_name     check_ping
     command_line     $USER1$/check_ping -H $HOSTADDRESS$ -w 3000,20% -c 5000,50% -p                                                                   
}

And same problem:
Info: /bin/sh: /check_ping: not found

Gauthier

--
Gauthier DOUCHET