Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Windows 7 64-bit... no context menu :-(

2011-12-16
2012-12-30
  • ParkSFTerex
    ParkSFTerex
    2011-12-16

    Okay… yet another issue with enabling the 7zip context shell menu in Windows 7 64-bit.  Yes, there are millions of threads already.  Yes, I've gone through them and tried those resolutions with no success.  Hoping someone can help.  :-(

    Issue: user cannot enable 7zip (64-bit) shell context menu on Windows 7 64-bit

    System:
      * Windows 7 Professional 64-bit (clean install on a new laptop)
      * i7-2640M, 8GB
      * user account is administrator

    Steps:

    1. User uninstalls previous 7z instance (have tried installing so many versions….)
    2. User downloads 7z920-x64.msi from sourceforge
    3. User installs 7z920-x64.msi.  All defaults are selected.  Installation completes successfully.
    4. System does not associate .zip with 7z (**SYMPTOM 1**)
    5. System does not show 7z context menu when user right-clicks on a .zip file (**SYMPTOM 2**)
    6. User navigates to C:\Program Files\7-Zip
    7. System displays 7zFM.exe in this directory
    8. User right-clicks 7zFM.exe
    9. User selects "Run as administrator" in context menu
    10. System opens 7z File Manager
    11. User goes to menu: Tools > Options
    12. In "System" tab, all boxes are checked (weird, b/c .zip wasn't associated, as in Step 4)
    13. User goes to "7-zip" tab
    14. In "7-zip" tab, all boxes are checked EXCEPT "Integrate 7-Zip to shell context menu"
    15. User checks the box "Integrate 7-Zip to shell context menu"
    16. User clicks "Okay"
    17. System returns to 7z File Manager screen (no error message)
    18. User closes 7z FM
    19. User ends all explorer.exe processes
    20. User runs new explorer.exe process
    21. System now recognizes (associates) .zip with 7z (**RESOLUTION 1; solves SYMPTOM 1**)
    22. System does not show 7z context menu when user right-clicks on a .zip file (**SYMPTOM 2, not resolved**)
    23. User runs 7zFM.exe (as administrator) again…
    24. User goes to menu: Tools > Options > "7-zip" tab
    25. System displays "Integrate 7-Zip to shell context menu" as unchecked

    post-conditions:
      * all filetypes are associates with 7z
      * shell context menu does not appear
      * ShellExView (shexview-64) shows two 7z extensions as Enabled (Type = Context Menu and Drag & Drop Handler)
      * user cries pitifully in the corner of the room because precious, precious 7z context menu won't load

    Any thoughts?  Feedback?  The issue seems to be that no matter what I try, I cannot get the selection for the "Integrate 7-Zip to shell context menu" to be checked.

    I have also tried the same steps with the new beta version (7z922-x64.msi) as well as with 4.65 (7z465-x64.msi); no luck, same result… the "Integrate 7-Zip to shell context menu" (and equivalent in 4.65) does not stay selected.

    I have tried the same in Windows 7 Safe Mode, but the same issue occurs.

    Any help is greatly appreciated!

     
  • I've never seen exactly the situation you describe.  I think it's just install over install that screwed Windows up. there is probably some registry ket that you could delete that would make everything blank and you could re-associate the relevant data types and everything would just work.  As to what key that is, I have no idea.

    Doing it the way you are doing it (try all sorts of different versions of the same program, install and uninstall over and over) is a good way to screw a system up.

    What I do when I get my systems to that point is to reinstall Windows, but that's probably not what you want to hear.

     
  • Fallon
    Fallon
    2011-12-17

    Maybe give 'FileMenu Tools' a spin.
    It's freeware for the right-click menu.
    After you have tried ..
    - Uninstall 7-Zip, reboot
    - Start  C:\Windows\regedit.exe
    .
    - Hit 'CTRL+F', search for 7-Zip
    - delete specific 7-Zip entries, context ones and All.
    - install 7-Zip.

     
  • Rik Rasmussen
    Rik Rasmussen
    2011-12-18

    One of my primary reasons for using 7-Zip for years now was the inclusion on the menus. Just installed new hardrive, installed Windows 7 64 bit, installed 7-Zip, and it doews not appear on menus when I right click on zipped file.  : (

     
  • Rik Rasmussen
    Rik Rasmussen
    2011-12-18

    disregard, no file types were associated, once I associated the list of file types 7-Zip appeared in menus. Seems program has changed however since my last version, the menu item opens File Manager rather than offering "extract here", etc.

     
  • Trevor Wood
    Trevor Wood
    2012-05-09

    I've got exactly the same problem - but on a virgin install of Windows 7 64 bit and 7Zip. When right clicking on a file or directory there is nothing about 7zip. In the options menu "Integrate 7-Zip to shell context menu" and "Cascade context menu" are both ticked, but no sign of 7Zip in the right click :-(

     

  • Anonymous
    2012-05-15

    HAD the same problem. Searched registry for 7-zip and immediatly found security issue on HKCR/*/shellex/ContextMenuHandler/s7-Zip. Was getting access denied. Went into parent key and updated permissions to push to all child objects. As soon as it was done, was able to see contents of key, and context menu worked without a tskill explorer.

     
  • Trevor Wood
    Trevor Wood
    2012-05-16

    mouseware - what did you actually have to do - step by step. Thanks

     

  • Anonymous
    2012-05-16

    1. open regedit
    2. open HKEY_CLASSES_ROOT
    3. open *
    4. open shellex
    5. open right click on ContextMenuHandlers and go to permissions
    6. click on Advanced
    7. check "Replace all child objects permissions with inheritable permissions form this object"
    8. hit OK a few times
    9. try to right click on a file and see if it shows up.

     
  • Trevor Wood
    Trevor Wood
    2012-05-16

    No - sorry, didn't do anything, even after a reboot :-(

     

  • Anonymous
    2012-05-17

    two questions.. one do you have the 7zip key under the contextmenuhandlers, and if so what's the value for the default string? second what happens if you click on my computer at the top of registry editor and do a find (f3) for anything matching 7-Zip? that's how i found my issue, it gave me an error on the first occurrence because it didn't have permission to search that key.

     
  • Trevor Wood
    Trevor Wood
    2012-05-17

    there is a 7-Zip key, value {23170F69-40C1-278A-1000-000100020000}

    I find a load of 7-zip entries, all of which I appear to have access to. I've just noticed though, that my copy of 7-zip has installed in the "Program Files (x86)" directory. Should it be in the "Program Files" directory, which'll mean I've got the wrong version. I thought I'd got the 64 bit version downloaded and installed, but on checkign it's the 32 bit version. I'll uninstall that and install the 64 bit version and see what happens

     
  • Trevor Wood
    Trevor Wood
    2012-05-17

    Duh!  - it was the 32 bit edition I had installed. The 64 bit has now replaced it and it's working fine. Sorry to bother y'all and thanks for the help

     
  • Martin Garnica
    Martin Garnica
    2012-07-07

    I have the same problem, I tried installing the version of 32 and 64 and does not give me the context menu. I have done everything and just get to the same point. Seeing this problem I thought I had found the light but it was not as expected.
    I have windows 7 - 64bit

    Someone with some solution. mouseware? Thank you.


    Translation from Spanish by google translator.

     
  • Trevor Wood
    Trevor Wood
    2012-07-07

    garniquilla - when I installed the correct bit version it worked fine. Make sure you've got the c64 version

     
  • chesthar lp
    chesthar lp
    2012-07-10

    7zip programmers has nothing to do with your problems at all.There is some programs thas mess up the registry and blocks the context menu not only for 7zip but many other programs.If you make clean install of windows first of all install 7zip withouth any drivers or programs or updates.Then install all other programs and after every program installed restart and check if 7zip works fine.
    One of the program that block the context menu of 7zip is "better file renamer".If you have installed this program on 64 bit windows uninstall it and the context menu shoul work fine!

     
  • Martin Garnica
    Martin Garnica
    2012-07-11

    Greetings trevorwood, chesthar.

    Just back to say he already solved the problem. Enter another page of the forum and follow the instructions. Apparently the problem was to install the two versions, the 32 and 64. But an uninstall of the two and a registry clean, but the reinstatement of 64 fixed the problem. Thank you.

     
  • jave
    jave
    2012-11-13

    FINALLY PEOPLE I SOLVED IT !!! :D Its all about having a 32 or 64 bit system and 7zip ! You CAN download the latest 7zip but first look if your opration system is 32 or 64bit and THEN download the RIGHT version (both are on the 7zip main page 7-zip.org :)
    Dont forget also these steps on Windows Vista/Windows 7
    8. User right-clicks 7zFM.exe
    9. User selects \\\\\\\"Run as administrator\\\\\\\" in context menu

     
  • Perhaps a little note in the options screen to let people know to run the program as admin would be helpful. Saves lots of people lots of time searching for the solution.