Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

"can not open mapping"

2011-09-10
2012-12-07
  • Gero Krüger
    Gero Krüger
    2011-09-10

    I've got a problem with my 7-zip-installation on Win XP.
    when I right-click on a zip file and choose "extract here" I get the message above ("can not open mapping").
    when I choose "open" I can open the 7-zip file manager and from there I can extract the files.
    I deinstalled 7-zip, cleaned the registry and reinstalled it (9.20) - it's always the same.
    googling I didn't find even the message text anywhere - so I seem to be the only person in the world with this problem …

    one more thing: 7-zip worked correctly for years, and I don't remember what change on my system it was that it didn't work anymore.

    can anybody help me?

     
  • fernando
    fernando
    2011-09-10

    ("can not open mapping").

    Is 7-Zip being sandboxed?

     
  • Igor Pavlov
    Igor Pavlov
    2011-09-11

    uninstall 7-Zip.
    reboot system.
    check that there is no 7-Zip folder in Program files.
    install 7-zip again.

     
  • Peat
    Peat
    2011-10-06

    I seem to be experiencing the same issue as geradok.
    Uninstalling, rebooting, removing the 7-zip folder and reinstalling 7-zip did not help (at least in my case).

    An "interesting" thing though is that this is also happening on older versions of 7-zip (for example 4.65)… So, maybe 7-zip is not the direct problem, but something else on Windows XP? Any ideas to what that might be?

    I don't use 7-zip every day, so it's difficult for me to recall what might have changed something to create this problem for 7-zip :(

     
  • Igor Pavlov
    Igor Pavlov
    2011-10-06

    Try same command via context menu in 7-Zip File Manager.
    If it works OK, try to find the problem:
    1) Uninstall 7-Zip,
    2) Reboot
    3) Check that there is no 7-Zip context menu item in Explorer.
    4) Install 7-Zip

     

  • Anonymous
    2012-05-03

    I have the same problem.  I followed the pointers in 3 and 5 above.  Still have the same issue.  No work arounds available.  Pity that.

     
  • Tomiks
    Tomiks
    2012-07-11

    7-Zip context option doesn't work anymore. My friend also has this problem. We tried reinstall to different versions, including 9.28 alpha, and it doesn't help. OS: Win XP SP3 32-bit. Only message "can not open mapping" when you right click the option on zip file…

     
  • Tomiks
    Tomiks
    2012-07-11

    The same command via context menu in 7-Zip File Manager works ok. Problem is with Windows explorer.