Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

7-max doesn't detect it's enabled

2005-10-09
2013-04-24
  • I've got an Athlon64 with 3GB ram, running Windows 2003 standard server SP1 32bit (long story short, I was testing something for my job, and now I don't want to spend 2 days seting up XP again). I recently upgraded to 3GB ram, and since then, I've had problems getting Windows to hibernate, so I decided check if the problem would go away using 7-max (since it hides some memory from Windows).
    However, even though I created a 7-max entry in boot.ini and booted from it, 7-max still says that the system isn't configured for it. I tried allocating 2048MB, 1024MB and 1536MB to 7-max, but the result was always the same. My boot.ini for 7-max looks like this:
    multi(0)disk(0)rdisk(2)partition(6)\WINDOWS="Windows Server 2003, Standard (7-max)" /MAXMEM=1536 /3GB /fastdetect /noexecute=AlwaysOff
    (/noexecute=alwaysoff is there because I use Services for Unix, which otherwise don't work reliably).

    Any idea what's wrong?

     
    • Igor Pavlov
      Igor Pavlov
      2005-10-09

      7-max doesn't support Windows 2003.
      7-max also doesn't support some combinations like Windows XP SP2 /Athlon64, because probably it's impossible to disable PAE mode for such combination.
      You can hide memory with  /MAXMEM switch

       
    • Are there any plans to address these issues?

       
      • Igor Pavlov
        Igor Pavlov
        2005-10-11

        I have no plans to add support for win2003 or/and PAE mode.