If I want to include the SemanticCompoundQueries.php in my wiki, I'm obliged to include the SMW_QueryResult before
like this:
require_once('extensions/SemanticMediaWiki/includes/storage/SMW_QueryResult.php');
require_once('extensions/SemanticCompoundQueries.php');

otherwise I got this
Fatal error: Class 'SMWQueryResult' not found in E:\Website\AwayCity\vLocal\wiki\extensions\SemanticCompoundQueries.php on line 69

Regards,

Charles

On Thu, Nov 20, 2008 at 8:18 PM, Temlakos <temlakos@gmail.com> wrote:
Wait a minute! Where does that line appear? In what file, I mean?


require_once('extensions/SemanticMediaWiki/includes/storage/SMW_QueryResult.php');

I never put that in my LocalSettings.php. Is that required for Compound Queries to work?

Temlakos

Charles Epaillard wrote:
Thanks Yaron as well.
I think the line Laurent is speaking about is
require_once('extensions/SemanticMediaWiki/includes/storage/SMW_QueryResult.php');
Regards,
Charles

On Thu, Nov 20, 2008 at 7:01 PM, Laurent Alquier <laurent@alquier.org <mailto:laurent@alquier.org>> wrote:

   Thanks Yaron !

   The extension is working great so far (although I ran into a few
   issues with the syntax of the 'require_once' line for my setup,
   but I got it to run).

   I have a related question - is anything planned for linked queries ?

   That would be the equivalent of joins in SQL - or feeding the
   result of one query into another one.

   Example: I have Cities located in Countries, and Companies located
   in Cities.
   The query I would like to see is : Ask for Companies in a
   particular Country.

   - Laurent

   ------------------------------------------------------------------------
   *From*: "Yaron Koren" <yaron57@gmail.com <mailto:yaron57@gmail.com>>

   *Sent*: Thursday, November 20, 2008 3:45 AM
   *To*: zehetner@molgen.mpg.de <mailto:zehetner@molgen.mpg.de>,
   Temlakos <temlakos@gmail.com <mailto:temlakos@gmail.com>>

   *Subject*: Re: [Semediawiki-user] New extension: Semantic Compound
   Queries


   Gu - Thanks; I never tested it with multi-value properties -
   hopefully I can try it out at some point and see what the problem is.

   Temlakos - it's odd that the code causes regular #ask queries to
   not work... my guess is that it's due to the hook processing,
   which is somehow failing in MediaWiki 1.12 - I've only tested it
   in MW 1.13 and 1.14. Unfortunately I can't think of a solution,
   short of waiting to see if other people have the same problem in
   MW 1.12 or earlier and are able to debug it.

   -Yaron


   -------------------------------------------------------------------------
   This SF.Net email is sponsored by the Moblin Your Move Developer's
   challenge
   Build the coolest Linux based applications with Moblin SDK & win
   great prizes
   Grand prize is a trip for two to an Open Source event anywhere in
   the world
   http://moblin-contest.org/redirect.php?banner_id=100&url=/
   <http://moblin-contest.org/redirect.php?banner_id=100&url=/>
   _______________________________________________
   Semediawiki-user mailing list
   Semediawiki-user@lists.sourceforge.net
   <mailto:Semediawiki-user@lists.sourceforge.net> ------------------------------------------------------------------------


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
------------------------------------------------------------------------

_______________________________________________
Semediawiki-user mailing list
Semediawiki-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/semediawiki-user