S Page <info@skierpage.com> wrote on 11/30/2007 06:18:03 AM:

> Rogalon wrote:
> > I'm having a problem defining annotations in templates and I can't figure
> > out what I am doing wrong. The annotations and the factpages don'tappear on
> > any articles where the templates are used. The annotations are also not
> > added to the database...
>
> It looks OK and it seems to work on ontoworld.org
> (http://ontoworld.org/wiki/Template:Test3 , you can preview the template
> invocation by modifying the Sandbox page)
>
> But start simple.  Do simple annotations (like [[version:=1]]) work as
> described in "Testing your Installation" in INSTALL?  If yes, then copy
> http://ontoworld.org/wiki/Template:Test to your wiki; does that simple
> semantic template work?  If yes, then maybe you have a problem with the
> ParserFunctions extension.

Thanks for the hint. I figured out what my problem was. We use a lot of namespaces in our internal wiki and I had to enable these in the SMW Templates... After doing that everything worked out perfectly.

  Thanks again and greeting, Roga
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Steinberg Media Technologies GmbH, Neuer Hoeltigbaum 22-32, D-22143 Hamburg, Germany
Phone: +49 (40) 21035-0 | Fax: +49 (40) 21035-300 | www.steinberg.net
Managing Director: Kazunori Kobayashi, Takuya Nakata
Registration Court: Hamburg HRB 86534
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -