Hey,

> If no tags for dev versions exist, take latest released and hope for the best. Good luck.

If you want to use a dev version, then use the appropriate branch, such as master. "dev-master" as version constraint. Using tags in this context makes little sense.

> Ensure all packages are set to install development versions in composer.json

Only the one you want to work on - no need to bother with the rest.

For the rest the doc looks reasonable enough.

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil. ~=[,,_,,]:3
--