Hey Lists,

ok, as far as I understand

include_once( __DIR__ . '/vendor/autoload.php' );

...is meant to be...

require_once( __DIR__ . '/../vendor/autoload.php' );

...and autoload.php will resist in wikiroot/vendor together with additional
packages which are not mediawiki-extensions.

We do not need multiple autoloader.php.

I'm not following you here. If you think there is a bug somewhere, please file it on bugzilla, with steps on how to reproduce it.

Well for example if I want to install an extension locally from disk
(zip-archive) into directory extensions I have to change

If I understand your question correctly, then I already answered this in the last paragraph here: http://www.bn2vs.com/blog/2013/11/24/upgrading-an-extension-that-now-uses-composer/

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil. ~=[,,_,,]:3
--