Latest dev code no longer contains the old store. So 1.9 will not support it. Your extension ought to use SMWs storage layer so it is not dependent on a specific version of some store implementation.

Sent from my HTC one X.

On 25 Mar, 2013 10:06 AM, "Samuel Lampa" <samuel.lampa@gmail.com> wrote:
Ah, found out that I have to set:

$smwgDefaultStore  =  'SMWSQLStore2';


Any hints for easiest migration of code that uses SMWSQLStore2 is highly
appreciated though!

(Becoming rusty with SMW stuff :| )

BR
// Samuel

On 03/25/2013 02:29 PM, Samuel Lampa wrote:
> Hi, I was wondering what the support is supposed to be for
> SMWSQLStore2 in the latest SMW?
>
> I have realized that RDFIO [1] is currently using it, which was making
> it non-compatible with SMW 1.9. After updating the inclusion path of
> it to th new one [2] I get further, but then I get the following
> error, indicating that a table is missing:
>
> A database query syntax error has occurred. This may indicate a bug in
> the software. The last attempted database query was:
>
>    |(SQL query hidden)|
>
> from within function "|SMWSQLStore2::getSMWPageIDandSort|". Database
> returned error "1146: Table 'smw.smw_ids' doesn't exist (localhost)".
>
> Is this expected, and how can I fix it?
>
> Btw, what would be the easiest path for migrating to SMWSQLStore3?
>
> BR
> // Samuel
>
> [1]http://www.mediawiki.org/w/index.php?title=Extension:RDFIO
> [2] includes/storage/compatSQLStore/SMW_SQLStore2.php
>


--
Developer at SNIC-UPPMAX www.uppmax.uu.se
Developer at Dept of Pharm Biosciences www.farmbio.uu.se


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Semediawiki-devel mailing list
Semediawiki-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/semediawiki-devel