Hey,

We want to use the latest wmf version of MediaWiki as the base platform of our wiki. Is this a wise idea in your opinion or should we use the stable version?

These versions of MediaWiki tend to be pretty stable on themselves. However, if you use them, you might end up running into compatibility issues with the latest release of SMW. To avoid that, you could run the latest code of SMW, which most of the time works fine with these WMF MW versions, but running the latest SMW code (ie git master) can lead to stability issues. I'm running the latest of both, and so is translatewiki.net. It works as long as occasional breakage (which is usually fixed pretty quickly) is acceptable to you.

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil.
--