Hey,

You raise some good questions. I'm just going to stick with some comments on the mentioned MediaWiki compatibility.

> # SMW 1.8 supports MW 1.17/1.18+

It supports 1.17 up to 1.20, and probably 1.21 as well.

> # SMW 1.9 is planned to support MW  1.19/1.20/1.21 / PHP 5.3 or greater

Indeed, 1.19 to 1.21.

> # SMW 1.10 is planned to support MW 1.20 (or 1.21 pending on the release date)

This release is scheduled for July 2013. That's only a bit over a year since 1.19, and people have made it clear they want this LTS to be supported for a while. So I'm against dropping MW 1.19 support in SMW 1.10 (assuming we stay on the release schedule this time). Let's drop it in 1.11?

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil.
--