Hey,

> Shouldn't we hold these requirements in the extensions? [1]

These docs are for MediaWiki 1.19. 1.20 does require 5.3 or later. Furthermore, I send a mail to the lists about using PHP 5.3 in the next version of SMW, and no one complained. And several extensions I maintain already require it, and no one complained about that either. So do you have any specific reason for not using it outweighing the advantages? :)

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil.
--