I have also seen that currently SMW\Test and SMW\Tests (or was it
SRF\Test, SRF\Tests) are used, which should it be?
"Test", not "Tests". At least that's the rule I've been following over the past few months.
can we use SMW\Store
instead of SMW\SQLStore
Why not both? The store stuff into SMW\Store and the SQLStore classes into SMW\SQLStore or perhaps SMW\Store\SQLStore.
I've started a new format and right now it uses the SRF namespace
but I'm not really sure that it should stay this way since it is
really an extension of the SMW\Printer (or SMW\Formats) namespace
rather than being part of the SRF namespace.
Nothing outside of SMW should be putting things into the SMW namespace. Having namespaces for more core SMW components such as result printers would be nice. However we need to be careful with those components that are used outside of SMW, since moving things into namespaces would break compatibility there. We probably should outline and discuss the namespace structure we want to use a bit more before throwing real effort at it :)
Jeroen De Dauw
Don't panic. Don't be evil.