Hey,

I recently wrote two blog posts filling gaps in our documentation, after noticing people kept asking the same questions.

The first one is aimed at developers, and explains how to make extensions compatible with, and installable via, Composer: http://www.bn2vs.com/blog/2013/11/24/introduction-to-composer-for-mediawiki-developers/

The second one is aimed at users, explaining how to upgrade from an extension version where Composer is not used, to one where it is. ie from SMW 1.8 to SMW 1.9 beta. http://www.bn2vs.com/blog/2013/11/24/upgrading-an-extension-that-now-uses-composer/

I hope this helps developers in increasing the amount of extensions that can be installed in a nice way, and helps users to test SMW 1.9 beta.

Cheers

--
Jeroen De Dauw
http://www.bn2vs.com
Don't panic. Don't be evil. ~=[,,_,,]:3
--