Hi,

Stephan - you make a good point about being able to get a working SB for a specific MediaWiki version. If you, or someone else, actually wanted an SB version that worked with MediaWiki 1.16, I could probably get that by going through all the tarballs for SB (they're all still available on the Google Code site), looking through the version histories of all the extensions, and matching up the dates. It would take some time, though.

As to creating new Semantic Bundles on the fly that match some criteria - i.e., using some set of Git tags - that gets complicated by the fact that not all of the extensions have consistent tagging. Some (like, I'm afraid to say, Semantic Forms Inputs, don't have any tags) - there are the automatic tags applied for MediaWiki versions, but those are not reliable as far as guaranteeing either compatibility or stability of the code.

In general, ensuring the compatibility of Semantic Bundle is about the level of difficulty one would expect for a package holding 22 extensions, with varying levels of maintenance for each. Of course, some of these extensions matter more than others - if, say, the Arrays extension doesn't work, not that many people will notice. (No offense to Arrays users.) And some extensions might be worth removing entirely - like Semantic Tasks, a little-used extension that no longer seems to be maintained. Nevertheless, trying to do anything sophisticated with the full set of extensions would take a fair amount of work. On the other hand, having something simple, like a link on the SB page to the best SB release for every MediaWiki version, might not be that hard, and it could be quite helpful.

Mark - thanks for clarifying the LTS release thing. As for having releases of MediaWiki and the Semantic Bundle together, it's an interesting idea, though it probably belongs in a separate thread.

-Yaron

On Mon, Feb 25, 2013 at 12:20 PM, Mark A. Hershberger <mah@everybody.org> wrote:
On 02/25/2013 10:23 AM, Yaron Koren wrote:
> I don't know if everyone's aware of it, but the WMF people have
> actually declared MediaWiki 1.19 to be the official LTS version for
> the next two years - so people are supposed to be able to use 1.19 for
> the next two years without any worries.

Actually, that isn't the WMF people, but rather the Release Manager for
MediaWiki -- namely me. The MediaWiki community is going to be
supporting this, not the WMF. See
http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/67466
(the conversation is still going on).

When I put together the 1.20 MediaWiki tarball, I tried to do one with
the SMW Bundle but ran into problems. Some of those have been fixed,
but it would be great to have a MediaWiki tarball that includes the SMW
Bundle as well.

What do you think?

--
http://hexmode.com/

There is no path to peace. Peace is the path.
-- Mahatma Gandhi, "Non-Violence in Peace and War"




--
WikiWorks MediaWiki Consulting http://wikiworks.com