Hi Yaron

I just upgraded SF to version 2.0.1,

I did run into a conflict between my current theme and the jQuery initialization of SF.
I also saw your suggestion to disable jQuery calls in the skin itself - which is not an option since I am using jQuery plugins to enhance the interface.

Would it be possible to add support for a global variable where jQuery would be defined ?

I had to comment out this section of code in SF_Utils in order to make things work since I am already calling jQuery in my theme.

        if ( method_exists( 'OutputPage', 'includeJQuery' ) ) {
            $wgOut->includeJQuery();
        } else {
            $scripts[] = "$sfgScriptPath/libs/jquery-1.4.2.min.js";
        }

I haven't found a lot of details about '$wgOut->includeJQuery()' yet, which seems the default way to control inclusion of the library files.

--
- Laurent Alquier
http://www.linfa.net