I got it: 

the first time i set up the mediawiki with a db-username already existing (for other dbs). As a result, the MEdiaWiki was working allright with the DB, but the SemWiki extension was getting confused I guess. 

Then I re-installed the Media Wiki, and created a new db-username. The media wiki surprisingly added three users (instead of one): one with "%" as host-name, one with "localhost", and one with "localhost.localdomain". Just had to add some privileges to the "localhost" one and everything worked out fine.
If all this sounds pretty naive, im sorry i never played with wiki-installations before! 
cheers
mikele

Begin forwarded message:

From: Michele Pasin <m.pasin@open.ac.uk>
Date: 26 October 2006 18:33:07 BDT
To: semediawiki-user@lists.sourceforge.net
Cc: Denny Vrandecic <denny@nodix.de>
Subject: error with SQL-tables-creation

Hi all, 
is there anyone who can help me? I keep getting this error while installing:
-------
A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:

    (SQL query hidden)

from within function "SMW::MakeSemanticTables". MySQL returned error "1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-wiki.`smw_relations` ( subject_id INT(8) UNSIGNED NOT NULL, s' at line 1 (localhost)".
-------
I'm trying to install SemWiki on a mac runninng osX.4,  PhP 5, MySql 5.....
In LocalSettings.php, DB name, user and psw are written down, and are correct. The user has all privileges...
Thanks

michele






____________________________


Michele Pasin

Phd Student

Knowledge Media Institute

The Open University

Walton Hall

Milton Keynes

MK7 6AA

United Kingdom


Tel: 01908 858730

Email: m.pasin@open.ac.uk

< www.kmi.open.ac.uk/people/mikele >