Thanks, Markus! I updated from SVN and it works now.

   Sergey

On Feb 9, 2008 8:34 AM, Markus Krötzsch <mak@aifb.uni-karlsruhe.de> wrote:
On Samstag, 9. Februar 2008, Sergey Chernyshev wrote:
> Hmm. Looks like another instance of the same problem:
> http://www.techpresentations.org/Property:Works_at
>
> This time it's with "Has type" property which is probably handled
> separately. Markus, can you take a look?

Done in SVN. Anyone who faces that problem can directly download the file [1]
into his SemanticMediaWiki/includes/ directory.

Markus

[1]
http://svn.wikimedia.org/svnroot/mediawiki/trunk/extensions/SemanticMediaWiki/includes/SMW_DV_Types.php


>
> Thank you,
>
>           Sergey
>
>
> On Feb 7, 2008 3:21 PM, Sergey Chernyshev <
>
> semediawiki-devel@antispam.sergeychernyshev.com> wrote:
> > Yes, looks like this update solved the problem, thanks Markus.
> >
> >         Sergey
> >
> > On Feb 7, 2008 2:31 AM, Markus Krötzsch <mak@aifb.uni-karlsruhe.de> wrote:
> > > On Mittwoch, 6. Februar 2008, Sergey Chernyshev wrote:
> > > > I've updated my SMW on Tech Presentations from RC1 to SVN HEAD and it
> > >
> > > seems
> > >
> > > > that Semantic Links with empty text (actually not empty, but space to
> > >
> > > work
> > >
> > > > around pipe trick and make them invisible) are not parsed anymore -
> > > > on http://www.techpresentations.org/Category:Conference_Series
> > > >
> > > >         [[Has default form::Form:Conference Series| ]]
> > > >
> > > > Is now displayed on the page as [[Form:Conference Series|]] and it's
> > >
> > > not
> > >
> > > > supposed to display at all.
> > >
> > > Oops, that is fixed in SVN now. The change that introduced that problem
> > > was to
> > > make "[[Has default form::Form:Conference Series| ]]" disappear
> > > completely,
> > > instead of introducing a " " at their position. Now this should work
> > > correctly.
> > >
> > > > The relation does show up in Factbox, but Semantic Forms fails to
> > >
> > > recognize
> > >
> > > > them (it derives form assignments from such relations on Category
> > >
> > > pages).
> > >
> > > That is strange, since Special:Browse also shows the relation properly.
> > > So it
> > > is stored in the database and should be retreivable with the normal
> > > storage
> > > access methods. Which method do you use to retrieve the relation?
> > >
> > > Markus
> > >
> > > > I ran SMW_refreshData.php with -c -p -t and then without any. Twice.
> > > >
> > > > Any idea what might be happening?
> > > >
> > > >        Sergey
> > >
> > > --
> > > Markus Krötzsch
> > > Institut AIFB, Universität Karlsruhe (TH), 76128 Karlsruhe
> > > phone +49 (0)721 608 7362          fax +49 (0)721 608 5998
> > > mak@aifb.uni-karlsruhe.de          www  http://korrekt.org
> >
> > --
> > Sergey Chernyshev
> > http://www.sergeychernyshev.com/



--
Markus Krötzsch
Institut AIFB, Universität Karlsruhe (TH), 76128 Karlsruhe
phone +49 (0)721 608 7362          fax +49 (0)721 608 5998
mak@aifb.uni-karlsruhe.de          www  http://korrekt.org

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Semediawiki-devel mailing list
Semediawiki-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/semediawiki-devel




--
Sergey Chernyshev
http://www.sergeychernyshev.com/