Hi,
 
I am unclear about which version of php is really required for SMW and its extensions. A few weeks ago I had to upgrade to php5.2.5 to resolve date time problems but having installed a number of extensions and SMW upgrades I wasn't sure exactly which bit had caused the problem!  Although the intallation instruction for SMW says php5.x I am concerned about installing MW+SMW extensions on a server with php 5.1.2. Is this a common problem and was there a patch I could have used instead of upgrading?
 
I am also thinking about the upgrade path in general when using such (great)  'hot off the press' code. For example SMW runs on MW 1.11+ but Halo uses 1.12 - so is it reasonable to keep up with these extensions by upgrading the MW installation *without* upgrading the database tables etc ?
 
                                                  Thanks
 
                                                                Alex