Hey all,
I'm installing richmedia extension,
version 1.4.1_1
and though I've run all the patches, and I see the "attached documents" interface on my page, clicking ">> Attach File" only causes the page to reload; there's no opportunity to upload the file.

In addition, in the wsyswyg editor, I've see the "upload media" button, but clicking on it only produces the javascript error: 
top.fb.loadAnchor is not a function
http://ssemtestdb00/metwikiupgrade/extensions/FCKeditor/plugins/mediaupload/fckplugin.js
Line 36

Any ideas what I can do?
I've got all my smwhalo code from the zip files, here:
http://sourceforge.net/projects/halo-extension/files/



Also, why does the version information for RM say:
(Version 1.4.1_1-for-SMW-1.4.x)
When then documentation says SMW 1.5.x is required?

here's all my version information:
MediaWiki 1.15.3 (r76688)
PHP 5.2.9 (apache2handler)
MySQL 5.1.33-community

Semantic Forms (Version 1.9.1_1)
Character Escapes (Version 0.9.1
Header Tabs (Version 0.8)
ParserFunctions (Version 1.1.1)
Rich Media Extension (Version 1.4.1_1-for-SMW-1.4.x)
Semantic MediaWiki (Version 1.5.1_1)
SMWHalo Extension (Version 1.5.1_4-for-SMW-1.5.1 [B47])
StringFunctions (Version 2.0.3)
SvgFunctions (Version 0.0.1)
[ URL Arguments] (Version 1.0)
Variables (Version 1.3)
ARCLibrary (Version Template:$VERSION [BTemplate:$BUILDNUMBER])
LDAP Authentication Plugin (Version 1.2c)
WYSIWYG extension (Version 1.3.2_1, FCK 2.6.4 Build 21629)


Thanks guys! Once I get all this installed and working, I'll probably package up the whole thing as a "functional, stable set."