Hi Yaron,

First of all thank you for this extension. I have been looking forward for it for long.

I have a template Timeline with
{{#set_internal:StatusObject
|ObjectOfPage={{{Object Of Page|}}}
|Status={{{Status|}}}
|StatusFromDate={{{Status From Date|}}}
|StatusChangeNotes={{{StatusChangeNotes|}}}
}}

On Page1 there is a template call
{{Timeline
|Object Of Page={{PAGENAME}}
|Status=Scoping
|Status From Date=2007/06/01
}}

On Page1(same as above) there is a ask query
{{#ask: [[StatusObject::+]] [[ObjectOfPage::{{PAGENAME}}]]
|mainlabel=-
|?Status = Status
|?StatusFromDate = From Date
|?StatusChangeNotes = Notes
|sort=StatusFromDate
}}

On doing refresh multiple statusobjects as page1#1, page1#1, page1#1... got created.
These are shown in browse and in ask query.

My system conf is :
MediaWiki 1.15.0
PHP 5.2.6-1+lenny3 (apache2handler)
MySQL 5.0.45-log
Semantic Internal Objects (Version 0.1)
Semantic MediaWiki (Version 1.4.2)

Is this version of Mediawiki compatible with this extension
because on Extension:SIO page it is there as >1.11.*
but in README of SIO under ==Requirements== it is written as
 This version of the Semantic Internal Objects extension requires MediaWiki 1.8 or higher and Semantic MediaWiki 1.4 or higher.

I have placed this as last line in funtion deleteSemanticData(SMWWikiPageValue $subject)
wfRunHooks('smwDeleteSemanticData', array($subject));
line no in my version being 1808

Is there a way to correct this probelm.

With Regards
Sravanthi