Why not revert the changes that caused the problem, and re-release version 1.4.2?


On Fri, Feb 13, 2009 at 8:28 AM, Markus Krötzsch <markus@semantic-mediawiki.org> wrote:
Hi all,

it turns out that our recent SMW 1.4.2 release included a last minute code
change that makes SMW 1.4.2 incompatible to MediaWiki 1.11, 1.12, and 1.13.
While we generally encourage upgrading to recent MediaWiki versions, it is not
our intention to break compatibility during a minor release! The problem can
be solved by replacing the file ./special/AskSpecial/SMW_SpecialAsk.php
shipped with SMW 1.4.2 with the file found at [1]. Users of MW 1.14.0 or
greater are not affected.

The problem is due to a lack of coordination among the MediaWiki developers
(many people contribute code directly, and they may not be aware of SMW-
specific release plans or guidelines), and also to a lack of caution on my
part (the change happened on Monday after I had already finished most of my
tests for SMW 1.4.2 -- I should have repeated them on the changed code). Our
apologies to anyone who was affected.




Markus Krötzsch
Semantic MediaWiki    http://semantic-mediawiki.org
http://korrekt.org    markus@semantic-mediawiki.org

Open Source Business Conference (OSBC), March 24-25, 2009, San Francisco, CA
-OSBC tackles the biggest issue in open source: Open Sourcing the Enterprise
-Strategies to boost innovation and cut costs with open source participation
-Receive a $600 discount off the registration fee with the source code: SFAD
Semediawiki-user mailing list