On 17.07.2012 17:14, Jeroen De Dauw wrote:

> Shouldn't we hold these requirements in the extensions? [1]

These docs are for MediaWiki 1.19. 1.20 does require 5.3 or later. Furthermore, I send a mail to the lists about using PHP 5.3 in the next version of SMW, and no one complained. And several extensions I maintain already require it, and no one complained about that either. So do you have any specific reason for not using it outweighing the advantages? :)


Jeroen De Dauw
PHP 5.3 seems to be a "short-living phase" comparing to 5.1 and 5.2. It's already not targeted for major updates, only has minor fixes. While 5.4 is already mature enough, has traits (extremly useful) and square-bracket array syntax (lesser syntax monstruosity), a faster Zend machine with smaller memory footprint. If I were to decide, I'd stick till Christmas with 5.2, then would jump right to 5.4 branch. However, I do not decide. However, 5.3 is still better than 5.2, anyway (anonymous functions, SPL is always built-in and so on).